Banking - Instability for deposit and withdrawal services

Incident Report for Ebury Bank

Resolved

This incident has been resolved.
Posted Aug 22, 2025 - 15:43 GMT-03:00

Investigating

We are currently experiencing instability with our deposit and withdrawal services.
Posted Aug 22, 2025 - 15:13 GMT-03:00
This incident affected: Digitalfx (Banking WIthdraw API, Banking Deposit Service).