Major outage in EBB Services

Incident Report for Ebury Bank

Resolved

This incident has been resolved.
Posted Jul 31, 2026 - 10:21 GMT-03:00

Investigating

We are currently investigating the issue in the Pricing Service, which cascades down to FX Operations in some of our products.
Posted Jul 31, 2026 - 09:53 GMT-03:00
This incident affected: WebPayments, DigitalFX (Exchange-API, Portal, Quotes-API), and Payments (Exchange API).